Klipfolio system requirements

Supported web browsers

Klipfolio is compatible with most modern Web browsers.

Our Development Team regularly tests the latest version of each browser to ensure compatibility with Klipfolio. If necessary, the app is then enhanced to leverage any increased interactivity levels of the newer version.

It is suggested that you use the latest browser version, whenever possible. Our general policy is to support the latest browser version.

The following is a list of preferred Web browsers and versions.

Browser

Version*

Comments

Chrome 31 + Recommended browser
Firefox 24.5 ESR + Recommended browser
Internet Explorer 10+ (11+ recommended) Version 9 may be used for viewing the dashboard, but not editing Klips.
Safari (Mac) 8+

*Valid as of April 2015. Subject to change.

**Supported mobile operating systems and devices

Klipfolio for iPhone app (available on iTunes)

  • The Klipfolio for iPhone app is also compatible with the iPad and iPod Touch.
  • Require iOS 8.3 or later.
  • Optimized for iPhone 5 and above.

Klipfolio for Android (available on Google Play)

  • Klipfolio for Android may work with Android tablets.
  • Requires Android 5 and above.

**Valid as of December 2015. Subject to change.

Feedback and Knowledge Base